CRAN Package Check Results for Package shinyML

Last updated on 2021-06-24 07:50:27 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.0.1 15.22 101.18 116.40 NOTE
r-devel-linux-x86_64-debian-gcc 1.0.1 11.36 76.60 87.96 NOTE
r-devel-linux-x86_64-fedora-clang 1.0.1 146.13 NOTE
r-devel-linux-x86_64-fedora-gcc 1.0.1 135.16 NOTE
r-devel-windows-x86_64 1.0.1 22.00 123.00 145.00 NOTE
r-devel-windows-x86_64-gcc10-UCRT 1.0.1 ERROR
r-patched-linux-x86_64 1.0.1 12.90 95.67 108.57 NOTE
r-patched-solaris-x86 1.0.1 193.80 NOTE
r-release-linux-x86_64 1.0.1 13.77 95.00 108.77 NOTE
r-release-macos-arm64 1.0.1 NOTE
r-release-macos-x86_64 1.0.1 NOTE
r-release-windows-ix86+x86_64 1.0.1 24.00 98.00 122.00 NOTE
r-oldrel-macos-x86_64 1.0.1 OK

Check Details

Version: 1.0.1
Check: LazyData
Result: NOTE
     'LazyData' is specified without a 'data' directory
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-devel-windows-x86_64, r-patched-linux-x86_64, r-patched-solaris-x86, r-release-linux-x86_64, r-release-macos-arm64, r-release-macos-x86_64, r-release-windows-ix86+x86_64

Version: 1.0.1
Check: package dependencies
Result: ERROR
    Packages required but not available: 'plotly', 'sparklyr'
    
    Package suggested but not available for checking: 'covr'
    
    See section 'The DESCRIPTION file' in the 'Writing R Extensions'
    manual.
Flavor: r-devel-windows-x86_64-gcc10-UCRT