CRAN Package Check Results for Package probably

Last updated on 2021-08-05 07:49:43 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.0.6 5.85 64.34 70.19 OK
r-devel-linux-x86_64-debian-gcc 0.0.6 4.56 47.95 52.51 OK
r-devel-linux-x86_64-fedora-clang 0.0.6 89.21 OK
r-devel-linux-x86_64-fedora-gcc 0.0.6 80.80 OK
r-devel-windows-x86_64 0.0.6 10.00 87.00 97.00 OK
r-devel-windows-x86_64-gcc10-UCRT 0.0.6 ERROR
r-patched-linux-x86_64 0.0.6 5.81 59.17 64.98 OK
r-patched-solaris-x86 0.0.6 117.40 OK
r-release-linux-x86_64 0.0.6 5.36 59.89 65.25 OK
r-release-macos-arm64 0.0.6 WARN
r-release-macos-x86_64 0.0.6 OK
r-release-windows-ix86+x86_64 0.0.6 14.00 86.00 100.00 OK
r-oldrel-macos-x86_64 0.0.6 OK
r-oldrel-windows-ix86+x86_64 0.0.6 21.00 84.00 105.00 OK

Check Details

Version: 0.0.6
Check: package dependencies
Result: ERROR
    Packages required but not available: 'dplyr', 'yardstick'
    
    Packages suggested but not available for checking:
     'ggplot2', 'parsnip', 'rsample', 'testthat'
    
    See section 'The DESCRIPTION file' in the 'Writing R Extensions'
    manual.
Flavor: r-devel-windows-x86_64-gcc10-UCRT

Version: 0.0.6
Check: re-building of vignette outputs
Result: WARN
    Error(s) in re-building vignettes:
    --- re-building ‘equivocal-zones.Rmd’ using rmarkdown
    Warning in engine$weave(file, quiet = quiet, encoding = enc) :
     Pandoc (>= 1.12.3) not available. Falling back to R Markdown v1.
    
    Attaching package: 'probably'
    
    The following objects are masked from 'package:base':
    
     as.factor, as.ordered
    
    
    Attaching package: 'dplyr'
    
    The following objects are masked from 'package:stats':
    
     filter, lag
    
    The following objects are masked from 'package:base':
    
     intersect, setdiff, setequal, union
    
    --- finished re-building ‘equivocal-zones.Rmd’
    
    --- re-building ‘where-to-use.Rmd’ using rmarkdown
    Warning in engine$weave(file, quiet = quiet, encoding = enc) :
     Pandoc (>= 1.12.3) not available. Falling back to R Markdown v1.
    
    Attaching package: 'probably'
    
    The following objects are masked from 'package:base':
    
     as.factor, as.ordered
    
    
    Attaching package: 'dplyr'
    
    The following objects are masked from 'package:stats':
    
     filter, lag
    
    The following objects are masked from 'package:base':
    
     intersect, setdiff, setequal, union
    
    Quitting from lines 175-201 (where-to-use.Rmd)
    Error: processing vignette 'where-to-use.Rmd' failed with diagnostics:
    polygon edge not found
    --- failed re-building ‘where-to-use.Rmd’
    
    SUMMARY: processing the following file failed:
     ‘where-to-use.Rmd’
    
    Error: Vignette re-building failed.
    Execution halted
Flavor: r-release-macos-arm64