CRAN Package Check Results for Package Runuran

Last updated on 2021-10-21 07:50:08 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.34 47.73 91.49 139.22 WARN
r-devel-linux-x86_64-debian-gcc 0.34 36.58 68.37 104.95 WARN
r-devel-linux-x86_64-fedora-clang 0.34 192.47 WARN
r-devel-linux-x86_64-fedora-gcc 0.34 183.30 WARN
r-devel-windows-x86_64 0.34 103.00 140.00 243.00 OK
r-devel-windows-x86_64-gcc10-UCRT 0.34 OK
r-patched-linux-x86_64 0.34 44.57 88.56 133.13 WARN
r-patched-solaris-x86 0.34 399.10 OK
r-release-linux-x86_64 0.34 42.68 89.18 131.86 WARN
r-release-macos-arm64 0.34 OK
r-release-macos-x86_64 0.34 OK
r-release-windows-ix86+x86_64 0.34 163.00 190.00 353.00 OK
r-oldrel-macos-x86_64 0.34 OK
r-oldrel-windows-ix86+x86_64 0.34 201.00 184.00 385.00 OK

Check Details

Version: 0.34
Check: top-level files
Result: WARN
     Output from running autoreconf:
     configure.ac:6: warning: The macro `AC_CONFIG_HEADER' is obsolete.
     configure.ac:6: You should run autoupdate.
     ./lib/autoconf/status.m4:719: AC_CONFIG_HEADER is expanded from...
     configure.ac:6: the top level
     configure.ac:61: warning: The macro `AC_HEADER_STDC' is obsolete.
     configure.ac:61: You should run autoupdate.
     ./lib/autoconf/headers.m4:704: AC_HEADER_STDC is expanded from...
     configure.ac:61: the top level
     configure.ac:68: warning: The macro `AC_HEADER_TIME' is obsolete.
     configure.ac:68: You should run autoupdate.
     ./lib/autoconf/headers.m4:743: AC_HEADER_TIME is expanded from...
     configure.ac:68: the top level
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-patched-linux-x86_64, r-release-linux-x86_64

Version: 0.34
Check: top-level files
Result: WARN
     Output from running autoreconf:
     configure.ac:6: warning: The macro `AC_CONFIG_HEADER' is obsolete.
     configure.ac:6: You should run autoupdate.
     ./lib/autoconf/status.m4:719: AC_CONFIG_HEADER is expanded from...
     configure.ac:6: the top level
     configure.ac:61: warning: The macro `AC_HEADER_STDC' is obsolete.
     configure.ac:61: You should run autoupdate.
     ./lib/autoconf/headers.m4:704: AC_HEADER_STDC is expanded from...
     configure.ac:61: the top level
     configure.ac:68: warning: The macro `AC_HEADER_TIME' is obsolete.
     configure.ac:68: You should run autoupdate.
     ./lib/autoconf/headers.m4:743: AC_HEADER_TIME is expanded from...
     configure.ac:68: the top level
     configure.ac:6: warning: The macro `AC_CONFIG_HEADER' is obsolete.
     configure.ac:6: You should run autoupdate.
     ./lib/autoconf/status.m4:719: AC_CONFIG_HEADER is expanded from...
     configure.ac:6: the top level
     configure.ac:61: warning: The macro `AC_HEADER_STDC' is obsolete.
     configure.ac:61: You should run autoupdate.
     ./lib/autoconf/headers.m4:704: AC_HEADER_STDC is expanded from...
     configure.ac:61: the top level
     configure.ac:68: warning: The macro `AC_HEADER_TIME' is obsolete.
     configure.ac:68: You should run autoupdate.
     ./lib/autoconf/headers.m4:743: AC_HEADER_TIME is expanded from...
     configure.ac:68: the top level
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc