CRAN Package Check Results for Package PAMpal

Last updated on 2021-06-19 07:48:58 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.9.14 42.95 294.37 337.32 OK
r-devel-linux-x86_64-debian-gcc 0.9.14 35.39 222.02 257.41 OK
r-devel-linux-x86_64-fedora-clang 0.9.14 408.16 NOTE
r-devel-linux-x86_64-fedora-gcc 0.9.14 412.90 NOTE
r-devel-windows-x86_64 0.9.14 55.00 323.00 378.00 OK
r-devel-windows-x86_64-gcc10-UCRT 0.9.14 ERROR
r-patched-linux-x86_64 0.9.14 43.48 278.41 321.89 OK
r-patched-solaris-x86 0.9.14 583.40 NOTE
r-release-linux-x86_64 0.9.14 41.91 280.90 322.81 OK
r-release-macos-arm64 0.9.14 ERROR
r-release-macos-x86_64 0.9.14 NOTE
r-release-windows-ix86+x86_64 0.9.14 75.00 315.00 390.00 OK
r-oldrel-macos-x86_64 0.9.14 NOTE
r-oldrel-windows-ix86+x86_64 0.9.14 60.00 288.00 348.00 OK

Check Details

Version: 0.9.14
Check: dependencies in R code
Result: NOTE
    Namespaces in Imports field not imported from:
     ‘rjson’ ‘rstudioapi’
     All declared Imports should be used.
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-patched-solaris-x86, r-release-macos-x86_64, r-oldrel-macos-x86_64

Version: 0.9.14
Check: package dependencies
Result: ERROR
    Package required but not available: 'PAMmisc'
    
    See section 'The DESCRIPTION file' in the 'Writing R Extensions'
    manual.
Flavors: r-devel-windows-x86_64-gcc10-UCRT, r-release-macos-arm64