CRAN Package Check Results for Package geodiv

Last updated on 2021-04-17 07:47:41 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.0.1 40.07 369.22 409.29 OK
r-devel-linux-x86_64-debian-gcc 1.0.1 30.27 266.06 296.33 OK
r-devel-linux-x86_64-fedora-clang 1.0.1 510.73 NOTE
r-devel-linux-x86_64-fedora-gcc 1.0.1 490.78 NOTE
r-devel-windows-ix86+x86_64 1.0.1 97.00 560.00 657.00 OK
r-devel-windows-x86_64-gcc10-UCRT 1.0.1 NOTE
r-patched-linux-x86_64 1.0.1 34.53 336.42 370.95 OK
r-patched-solaris-x86 1.0.1 725.90 NOTE
r-release-linux-x86_64 1.0.1 35.63 338.46 374.09 OK
r-release-macos-x86_64 1.0.1 NOTE
r-release-windows-ix86+x86_64 1.0.1 103.00 603.00 706.00 OK
r-oldrel-macos-x86_64 1.0.1 NOTE
r-oldrel-windows-ix86+x86_64 1.0.1 54.00 291.00 345.00 WARN

Check Details

Version: 1.0.1
Check: dependencies in R code
Result: NOTE
    Namespaces in Imports field not imported from:
     ‘phonTools’ ‘rgdal’ ‘rgeos’
     All declared Imports should be used.
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-devel-windows-x86_64-gcc10-UCRT, r-patched-solaris-x86, r-release-macos-x86_64, r-oldrel-macos-x86_64

Version: 1.0.1
Check: re-building of vignette outputs
Result: WARN
    Error(s) in re-building vignettes:
    --- re-building 'geodiv_vignette.Rmd' using rmarkdown
    Quitting from lines 82-101 (geodiv_vignette.Rmd)
    Error: processing vignette 'geodiv_vignette.Rmd' failed with diagnostics:
    package 'lattice' 0.20.38 was found, but >= 0.20.41 is required by 'rasterVis'
    --- failed re-building 'geodiv_vignette.Rmd'
    
    SUMMARY: processing the following file failed:
     'geodiv_vignette.Rmd'
    
    Error: Vignette re-building failed.
    Execution halted
Flavor: r-oldrel-windows-ix86+x86_64